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Foreword
This manual describes the functions and operating procedures of GateMODBUS.  To 
ensure correct use, please read this manual thoroughly before beginning operation.  
After reading the manual, keep it in a convenient location for quick reference in the event 
a question arises.  GateMODBUS is a software program that uses the Modbus protocol 
to acquire data from measurement instruments and transfer that data to DAQLOGGER 
or Remote Monitor.  

Note
•	 The contents of this manual are subject to change without prior notice as a result of 

improvements in the software's performance and functions.  
•	 Every effort has been made in the preparation of this manual to ensure the accuracy 

of its contents.  However, should you have any questions or find any errors, please 
contact your nearest YOKOGAWA representative as listed on the back cover of this 
manual.  

•	 Copying or reproducing all or any part of the contents of this manual without the 
permission of Yokogawa Electric Corporation is strictly prohibited.  

•	 Use of this product (software and this manual) on more than one computer at the 
same time is prohibited. Use by more than one user is also prohibited.

•	 Transfer or lending of this product to any third party is prohibited.
•	 Yokogawa Electric Corporation provides no guarantees other than for physical 

deficiencies found on the original disk or this manual upon opening the product 
package.

•	 License numbers will not be reissued. Please keep the license number in a safe 
place.

Copyrights
•	 Copyrights for the programs included on the CD-ROM are attributable to Yokogawa 

Electric Corporation.  

Trademarks
•	 DAQWORX, DAQLOGGER, and DAQEXPLORER are registered trademarks or 

trademarks of Yokogawa Electric Corporation.
•	 Microsoft and Windows are registered trademarks or trademarks of Microsoft 

Corporation in the United States and/or other countries.
•	 Adobe and Acrobat are registered trademarks or trademarks of Adobe Systems 

Incorporated.
•	 Company and product names that appear in this manual are registered trademarks or 

trademarks of their respective holders.
•	 The company and product names used in this manual are not accompanied by the 

registered trademark or trademark symbols (® and ™).

Revisions
•	 1st Edition		 June 2003
•	 2nd Edition		 February 2005
•	 3rd Edition		 June 2007
•	 4th Edition		 March 2008
•	 5th Edition		 January 2009
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Terms and Conditions of the Software License

NOTICE - PLEASE READ CAREFULLY BEFORE USE
Thank you very much for purchasing this medium containing a software program and related documentation provided by Yokogawa Electric Corporation (hereinafter called 
“Yokogawa”), and the program contained, embedded, inserted or used in the medium (hereinafter called the “Yokogawa Software Program”).
By installing the Yokogawa Software Program, you acknowledge that you understand and fully agree to the “Terms and Conditions of the Software License” (hereinafter called 
“Terms and Conditions”) which is written in the documentation and separately attached. Accordingly, the Terms and Conditions bind you.
The Yokogawa Software Program and its related documentation including ownership of copyright shall remain the exclusive property of Yokogawa or those third parties who 
grants Yokogawa the rights.
Yokogawa hereby grants you permission to use the Yokogawa Software Program on the conditions that you agree to the Terms and Conditions before you install it in or onto 
a computer.

IF YOU DO NOT AGREE TO THE TERMS AND CONDITIONS, YOU CANNOT INSTALL THIS MEDIUM, AND MUST PROMPTLY RETURN IT TO YOKOGAWA OR ITS 
DESIGNATED PARTY.

Terms and Conditions of the Software License
Yokogawa Electric Corporation, a Japanese corporation (hereinafter called “Yokogawa”), grants permission to use this Yokogawa Software Program (hereinafter called the 
“Licensed Software”) to you on the conditions that you agrees to the terms and conditions stipulated in Article 1 hereof.
You, as the Licensee (hereinafter called “Licensee”), shall agree to the following terms and conditions on the software license (hereinafter called the “Agreement”) when the 
Licensed Software is installed by the Licensee.
Please note that Yokogawa grants the Licensee permission to use the Licensed Software under the terms and conditions herein and in no event shall Yokogawa intend to 
sell or transfer the Licensed Software to the Licensee.

Article 1 (Licensed Software under these Terms and Conditions)
1.1	 The terms and conditions stipulated herein shall bind any Licensee who purchases the Licensed Software on the condition that the Licensee consents to agree to the 

terms and conditions stipulated herein.
1.2	 The “Licensed Software” and required number of license herein shall be specified in the following paragraphs (1) and (2) respectively. The Licensed Software means 

and includes all applicable programs and documentation, without limitation, all proprietary technology, algorithms, a factor, invariant, process and/or other know-how 
contained therein. These terms and conditions shall also govern any additional software to the Licensed Software inclusive of its version-up or revision-up if Yokogawa 
provides them to the Licensee.
(1)	 Licensed Software Name: Data Acquisition Software Suite DAQWORX
(2)	 Number of License: Same number as those media for the Licensed Software shall be acquired for installation.

Article 2 (Grant of License)
2.1	 Yokogawa grants the Licensee, for the purpose of single use, non-exclusive and non-transferable license of the Licensed Software with the license fee separately agreed 

upon by both parties.
2.2	 The Licensee is, unless otherwise agreed upon in writing by Yokogawa, not entitled to change, sell, distribute, transfer, or sublicense the Licensed Software.
2.3	 The Licensed Software shall not be copied in part or in whole except for keeping one (1) copy for back-up purpose. The Licensee shall secure or supervise the copy of 

the Licensed Software by the Licensee itself with great, strict, and due care.
2.4	 The Licensed Software remains the exclusive property of Yokogawa and, if any, those of third parties from whom Yokogawa is sublicensed (hereinafter such third party’s 

software is called “Third Party Software”, which may include any software program made or coded by affiliates of Yokogawa). In no event shall the Licensee dump, 
reverse assemble, reverse compile, or reverse engineer the Licensed Software so that the Licensee may translate the Licensed Software into other programs or change 
it into a man-readable form from the source code of the Licensed Software. Unless otherwise separately agreed upon by Yokogawa, Yokogawa shall not provide the 
Licensee the source code for the Licensed Software.

2.5	 The Licensed Software and its related documentation inclusive of its ownership of copyright shall be the proprietary property of Yokogawa or a third party who grants 
Yokogawa the rights. In no event shall the Licensee transfer, lease, sublicense, or assign any rights relating to the Licensed Software.

2.6	 Yokogawa may use or add copy protection in or onto the Licensed Software. In no event shall, regardless of the purpose, the Licensee remove or attempt to remove 
such copy protection.

2.7	 The Licensed Software may include the Third Party Software. In the case that Yokogawa is granted permission to sublicense to third parties by any licensors (sub-
licensor) of the Third Party Software under different terms and conditions than those stipulated in this  Agreement, the Licensee shall observe such terms and conditions 
of which Yokogawa notifies the Licensee in writing separately.

2.8	 In no event shall the Licensee modify, remove or delete a copyright notice of Yokogawa and its licenser contained in the Licensed Software, including any copy 
thereof.

Article 3 (Restriction of Specific Use)
3.1	 The Licensed Software shall not be intended specifically to be designed, developed, constructed, manufactured, distributed or maintained for the purpose of the following 

events:
a)	 Operation of any aviation, vessel, or support of those operations from the ground;
b)	 Operation of nuclear products, its facilities and/or radiation apparatus;,
c) 	 Operation of nuclear weapons, chemical weapons and/or biological weapons, or railroad; or
d)	 Operation of medical instrumentation directly utilized for humankind or the human body.

3.2	 Even if the Licensee uses the Licensed Software for the purposes in the preceding Paragraph 3.1, Yokogawa has no liability to or responsibility for any claims or 
damages arising out of the use or operations of the Licensed Software, and the Licensee agrees, on its own responsibility, to solve and settle the claims and damages 
and to defend, indemnify or hold Yokogawa totally harmless, from or against any liabilities, losses, damages and expenses (including fees for recalling the Products and 
reasonable attorney’s fees and court costs), or claims arising out of and related to the above-said claims and damages.

Article 4 (Warranty)
4.1	 The Licensee shall agree that the Licensed Software shall be provided to the Licensee on an “as is” basis when delivered. If defect(s), such as damage to the medium of 

the Licensed Software, attributable to Yokogawa is found, Yokogawa agrees to replace, free of charge, any Licensed Software on condition that the defective Licensed 
Software shall be returned to Yokogawa’s specified authorized service facility within  12 month from the delivery of Yokogawa after opening the Package at the Licensee’s 
expense. As the Licensed Software is provided to the Licensee on an “as is” basis when delivered, in no event shall Yokogawa warrant that any information on or in the 
Licensed Software, including without limitation, data on computer programs and program listings, be completely accurate, correct, reliable, or the most updated.

4.2	 Notwithstanding the preceding Paragraph 4.1, when Third Party Software is included in the Licensed Software, the warranty period and related conditions that apply 
shall be those established by the provider of the third party software.
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4.3	 When Yokogawa decides in its own judgement that it is necessary, Yokogawa may from time to time provide the Licensee with Release Upgrades specified by Yokogawa 
(hereinafter called “Release Upgrades”).

4.4	 Notwithstanding the preceding Paragraph 4.3, in no event shall Yokogawa provide Updates where the Licensee or any third party conducted renovation or improvement 
of the Licensed Software.

4.5	 Correction of nonconformity in the manner and for the period of time provided above shall be the Licensee’s sole and exclusive remedy for any failure of Yokogawa to 
comply with its obligations and shall constitute fulfillment of all liabilities of Yokogawa and any third party licensing the Third Party Software to Yokogawa (including any 
liability for direct, indirect, special, incidental or consequential damages) whether in warranty, contract, tort (including negligence but excluding willful conduct or gross 
negligence by Yokogawa) or otherwise with respect to or arising out of the use of the Licensed Software.

4.6	 THE FOREGOING WARRANTIES ARE EXCLUSIVE AND IN LIEU OF ALL OTHER WARRANTIES OF QUALITY AND PERFORMANCE, WRITTEN, ORAL, OR 
IMPLIED, AND ALL OTHER WARRANTIES INCLUDING ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE ARE 
HEREBY DISCLAIMED BY YOKOGAWA AND ALL THIRD PARTIES LICENSING THIRD PARTY SOFTWARE TO YOKOGAWA.

Article 5 (Infringement)
5.1	 If and when any third party should demand injunction, initiate a law suit, or demand compensation for damages against the Licensee under patent right (including utility 

model right, design patent, and trade mark), copyright, and any other rights relating to any of the Licensed Software, the Licensee shall promptly notify Yokogawa in 
writing to that effect.

5.2	 In the case of the preceding Paragraph 5.1, the Licensee shall assign to Yokogawa all of the rights to defend the Licensee and to negotiate with the claiming party. 
Furthermore, the Licensee shall provide Yokogawa with necessary information or any other assistance for Yokogawa’s defense and negotiation. If and when such a 
claim should be attributable to Yokogawa, subject to the written notice to Yokogawa stated in the preceding Paragraph 5.1, Yokogawa shall defend the Licensee and 
negotiate with the claiming party at Yokogawa’s cost and expense and be responsible for the final settlement or judgment granted to the claiming party in the preceding 
Paragraph 5.1.

5.3	 When any assertion or allegation of the infringement of the third party’s rights defined in Paragraph 5.1 is made, or when at Yokogawa’s judgment there is possibility of 
such assertion or allegation, Yokogawa will, at its own discretion, take any of the following countermeasures at Yokogawa’s cost and expense.
a)	 To acquire the necessary right from a third party which has lawful ownership of the right so that the Licensee will be able to continue to use the Licensed 

Software;
b)	 To replace the Licensed Software with an alternative one which avoids the infringement; or
c)	 To remodel the Licensed Software so that the Licensed Software can avoid the infringement of such third party’s right.

5.4	 If and when Yokogawa fails to take either of the countermeasures as set forth in the preceding subparagraphs of Paragraph 5.3, Yokogawa shall indemnify the Licensee 
only by paying back the price amount of the Licensed Software which Yokogawa has received from the Licensee. 

	 THE FOREGOING PARAGRAPHS STATE THE ENTIRE LIABILITY OF YOKOGAWA AND ANY THIRD PARTY LICENSING THIRD PARTY SOFTWARE TO YOKOGAWA 
WITH RESPECT TO INFRINGEMENT OF THE INTELLECTUAL PROPERTY RIGHTS INCLUDING BUT NOT LIMITED TO, PATENT AND COPYRIGHT.

Article 6 (Liabilities)
6.1	 If and when the Licensee should incur any damage relating to or arising out of the Licensed Software or service that Yokogawa has provided to the Licensee under 

the conditions herein due to a reason attributable to Yokogawa, Yokogawa shall take actions in accordance with this Agreement. However, in no event shall Yokogawa 
be liable or responsible for any special, incidental, consequential and/or indirect damage, whether in contract, warranty, tort, negligence, strict liability, or otherwise, 
including, without limitation, loss of operational profit or revenue, loss of use of the Licensed Software, or any associated products or equipment, cost of capital, loss 
or cost of interruption of the Licensee’s business, substitute equipment, facilities or services, downtime costs, delays, and loss of business information, or claims of 
customers of Licensee or other third parties for such or other damages. Even if Yokogawa is liable or responsible for the damages attributable to Yokogawa and to the 
extent of this Article 6, Yokogawa’s liability for the Licensee’s damage shall not exceed the price amount of the Licensed Software or service fee which Yokogawa has 
received. The Licensee agrees that Yokogawa shall be released or discharged from part or all of the liability under this Agreement if the Licensee modifies, remodels, 
combines with other software or products, or causes any deviation from the basic specifications or functional specifications, without Yokogawa’s prior written consent.

6.2	 All causes of action against Yokogawa arising out of or relating to this Agreement or the performance or breach hereof shall expire unless Yokogawa is notified of the 
claim within one (1) year of its occurrence.

6.3	 In no event, regardless of cause, shall Yokogawa assume responsibility for or be liable for penalties or penalty clauses in any contracts between the Licensee and its 
customers.

Article 7 (Limit of Export)
Unless otherwise agreed by Yokogawa, the Licensee shall not directly or indirectly export or transfer the Licensed Software to any countries other than those where Yokogawa 
permits export in advance.

Article 8 (Term)
This Agreement shall become effective on the date when the Licensee receives the Licensed Software and continues in effect unless or until terminated as provided herein, 
or the Licensee ceases using the Licensed Software by itself or with Yokogawa’s thirty (30) days prior written notice to the Licensee. When aforesaid termination or cease is 
occurred, the Licensee shall immediately destroy and/or eliminate the Licensed Software and related documents without retaining any copies or extracts thereof. However, 
upon specifically instructed by Yokogawa, they shall be returned to Yokogawa or its designated third party.

Article 9 (Injunction for Use)
During the term of this Agreement, Yokogawa may, at its own discretion, demand injunction against the Licensee in case that Yokogawa deems that the Licensed Software is 
used improperly or under severer environments other than those where Yokogawa has first approved, or any other condition which Yokogawa may not permit.

Article 10 (Termination)
Yokogawa, at its sole discretion, may terminate this Agreement without any notice or reminder to the Licensee if the Licensee violates or fails to perform this Agreement. 
However, Articles 5, 6, and 11 shall survive even after the termination.

Article 11 (Jurisdiction)
Any dispute, controversies, or differences between the parties hereto as to interpretation or execution of this Agreement shall be resolved amicably through negotiation 
between the parties upon the basis of mutual trust. Should the parties fail to agree within ninety (90) days after notice from one of the parties to the other, both parties hereby 
irrevocably submit to the exclusive jurisdiction of the Tokyo District Court (main office) in Japan for settlement of the dispute to the fullest extent allowed by applicable law.

Article 12 (Governing Law)
This Agreement shall be governed by and construed in accordance with the laws of Japan. The Licensee expressly agrees to waive absolutely and irrevocably and to the 
fullest extent permissible under applicable law any rights against the laws of Japan which may have pursuant to the Licensee’s local law.

Article 13 (Severability)
In the event that any provision hereof is declared or found to be illegal by any court or tribunal of competent jurisdiction, such provision shall be null and void with respect to 
the jurisdiction of that court or tribunal and all the remaining provisions hereof shall remain in full force and effect.

Terms and Conditions of the Software License
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Overview of This Manual

Structure of This Manual
This user’s manual consists of the following chapters.  

Chapter Title Description
1 Overview Gives an overview of the GateMODBUS software. 

Lists the PC requirements for running Gate-MODBUS and 
gives information about system configuration.

2 Operating Procedure Gives procedures for entering environment and data 
logging interval settings, and how to monitor the operational 
status of the software.

3 Detailed Description 
of Functions

Provides a detailed description of the functions of 
GateMODBUS.  Lists error messages, their causes, and 
their corrective actions.  

Index An alphabetical index of the manual's contents.

Scope of This Manual
This manual provides instructions on how perform basic operations with the software 
when running under Windows XP, Windows 2000, and Windows Vista.  For information 
regarding the basic operations of Windows, see the Windows user’s manual.

Conventions Used in This Manual
•	 Units
	 K 	Denotes 1024.		  Example: 10 KB
	 M 	Denotes 1024K.		  Example: 10 MB
	 G 	Denotes 1024M.		  Example: 2 GB

•	 Boldface Type
	 Hardware and software controls that the user manipulates such as dialog boxes, 

buttons, and menu commands are often set in boldface type.
	
•	 Subheadings
	 On pages in chapters 1 through 3 that describe operating procedures, the following 

subheadings are used to distinguish the procedure from their explanations.

			 

Procedure This subsection contains the operating procedure used to carry out
the function described in the current section. All procedures are
written with inexperienced users in mind; experienced users may
not need to carry out all the steps.

			   Note Calls attention to information that is important for proper operation 
of the instrument.
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Chapter 1	 Overview

1.1	 Overview of GateMODBUS Functions

GateMODBUS is a software program that uses the Modbus protocol to acquire data 
from other application software or measuring instruments with data output functions, 
and transfer the data to DAQLOGGER or Remote Monitor.  Using GateMODBUS allows 
you to monitor data on DAQLOGGER or Remote Monitor that was acquired not only by 
Yokogawa recorders, but also by other manufacturers’ measuring instruments as well.
Yokogawa’s DAQLOGGER is a software program that allows users to open a connection 
from their PC to various kinds of Yokogawa recorders (the mR, VR, DARWIN, DX, MV, 
and CX) and perform data logging and monitoring.
Yokogawa’s Remote Monitor is a software program that enables monitoring of data 
logged by recorders or data logging software.

Features
•	 Runs as a Windows application. 
•	 Supports the Modbus/RTU (serial) and Modbus/TCP (Ethernet) protocols.
•	 Allows you to read the input and holding registers from various measuring instruments. 
•	 Measurement can be performed at intervals of up to 0.5 seconds*.

*	 However, DAQLOGGER’s shortest interval is 1 second.  Also, the maximum speed of 0.5 
seconds may not be attainable depending on the amount of data being read, the response 
time of the device, and the communication speed.
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1.2	 System Overview

System
This software can perform data logging when connected with instruments (devices) 
meeting the following criteria.  
•	 The ability to perform communications using the Modbus/RTU (serial) or Modbus/TCP 

(Ethernet) protocol.  
•	 For serial communications,  the ability to operate under a baud rate of 4800, 9600, 

19200, or 38400.  
•	 The ability to read registers using one or both of the following two Modus function 

codes.  
•	 Function code 03: read holding registers
	 (register numbers: 40001-49999, 400001-465535)
•	 Function code 04: read input registers
	 (register numbers: 30001-39999, 300001-365535)

Software Requirements
Run DAQWORX under any of the following operating systems. 
•	 Windows 2000 Professional SP4
•	 Windows XP Home Edition SP2, SP3
•	 Windows XP Professional SP2, SP3 (excluding Windows XP Professional x64 Edition)
•	 Windows Vista Home Premium, SP1 (excluding the 64-bit edition)
•	 Windows Vista Business, SP1 (excluding the 64-bit edition)
The language displayed by the software under different language versions of the OS are 
as follows. 
OS Language Software Language
Japanese Japanese
Other English

Hardware Requirements
The following hardware are required to use GateMODBUS.  
•	 PC:						�      A PC that runs one of the OS above, and that meets the 

following CPU and memory requirements. 
								        When Using Windows 2000 or Windows XP
								�        Pentium 4, 1.6 GHz or faster				  

512 MB or more of memory
								        When Using Windows Vista
								        Pentium 4, 3 GHz or faster
								        2GB or more of memory
•	 Free disk space: 	 200 MB or more
•	 Communication device: 	 An Ethernet (when connecting to DAQLOGGER or Remote 

Monitor), or RS-232 port that is recognized by the operating 
system.  Also required for Ethernet communications with this 
software’s Modbus instruments), or RS-232 port 

•	 CD-ROM drive: 	 Used to install the software
•	 Peripheral devices: 	 A mouse supported by the operating system
•	 Monitor:					    When Using Windows 2000 or Windows XP
								�        A monitor supported by the OS of 1024 × 768 dot or higher and 

65,536 colors or more.
								        When Using Windows Vista
								�        A video card recommended for use with Vista and a monitor 

supported by the OS of 1024 × 768 dot or higher and 65,536 
colors or more.
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1.2  System Overview

Note
An RS-232 to RS-422-A/RS-485 converter is required to perform communications between the 
software and another Modbus device via RS-422-A/RS-485 (Yokogawa ML2 RS232C/RS485 
converter recommended).

System Configuration

		

TCP/IP connection
Monitor server protocol
Data transfer Remote monitor

Converter

PV

SP

SP2 3 4

MANAL 1 2 3

SET/ENT

A/M

Modbus/TCP devices

JUXTA
(VJET),
Temperature 
controllers

EthernetEthernet

Modbus/RTU devices

GateMODBUS

RS-422-A/RS-485

It is recommended that you run GateMODBUS and DAQLOGGER on separate PCs 
depending on the number of devices that the system supports and other factors affecting 
the load.  

Software Configuration

DAQLOGGER

Ethernet

Ethernet

GateMODBUS

Environment setting 
functions

Displays execution
and connection 

status

Writes to file

Environment
settings file

File read out

Status information

Executable
function

Remote Monitor

Modbus devices

Modbus/RTU
Modbus/TCP

GateMODBUS Configurator consists of two separate software functions.  The role of 
each function within the configurator is as follows: 
•	 Environment Setting Functions
	 Used to define model names, communication methods, and other parameters required 

for running the executable function. 
	 And operates in conjunction with the environment setting functions to display the 

practice status and connection status of DAQLOGGERs and Remote Monitors.
•	 Executable Function
	 The software reads data from the Modbus devices at fixed intervals.  It also acts as a 

monitor server, transferring data to DAQLOGGER and Remote Monitor.
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Chapter 2	 Operating Procedure

2.1	 Running and Exiting GateMODBUS

Running the Software
Procedure

1.	 From the Windows Start menu, choose Programs > YOKOGAWA DAQWORX > 
GateMODBUS > GateMODBUS.  

	 The GateMODBUS Configurator opens.

					   

Note
•	 When you start GateMODBUS, it is restored to the same status that was active during the 

previous session.
•	 If the program is closed while a process or service is running, the license will be considered to be “in use.” 

If the message, “Invalid license number. Please reinstall.” appears when restarting the program, it may 
indicate that the user is attempting to run a Gate program in excess of the number of available licenses. 

Starting GateMODBUS in Acquisition Start Mode
Procedure

1.	 From the Windows Start menu, choose Programs > YOKOGAWA DAQWORX > 
GateMODBUS > GateMODBUS, then right-click GateMXMW and select Create 
Shortcut.  

2.	 Right-click the shortcut icon and select Properties.  
3.	 Choose the Shortcut tab, then add /START to the right of the path in the Target 

box and click OK.  

					   

4.	 Choose the shortcut from the Windows Start menu.  The connection status of the 
previous session is restored, and acquisition begins. 

Exiting the Software
Procedure

1.	 Choose File > Exit from the menu bar, or click the X button at the right end of 
the title bar.  

	 GateMODBUS closes.  
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2.2	 Entering Environment Settings

The following settings can be entered using the configurator.  
•	 Serial port and Ethernet port settings (Serial Setting tab)
•	 Data acquisition conditions, communication retry (Scan Interval tab)  
•	 Tag settings (Tag Setting tab)
•	 Group settings (Group Setting tab)
•	 TCP/IP settings for the monitor server port (Port Setting tab)

Serial Port Settings 
Procedure

1.	 Click the Comm. Setting tab or choose View > Comm. setting from the menu bar.

	 The Serial Setting screen in displayed.

Select/deselect
all items

Drag to select a
range of items

Turns all selected 
items ON/OFFClick to turn a single item ON/OFF

Copies the setting in 
the first item of the 
selection to all of the 
items in the selection

Click to display a list

2.	 Set the port number, baud rate, and parity.  

	 Port number: ON (blue)/OFF (gray)

	 Baud rate: 4800, 9600, 19200, 38400

	 Parity: NONE, ODD, EVEN

3.	 Turn Ethernet ON (blue) or OFF (gray).  

4.	 Click Address.  The dialog box below opens.  
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2.2  Entering Environment Settings

5.	 Enter the IP address or host name and port number.  (The default port number for 
Modbus/TCP is 502.  Use this port number if no particular setting is required by 
the instrument.)

Data Acquisition Conditions, Communication Retry
Procedure

1.	 Click the Scan Interval tab or choose View > Scan Interval setting from the menu 
bar.

					   

2.	 Set the scan interval, timeout time, and number of retries.  

	 Logging interval:	 0.5–3600 sec.

	 Timeout time:	 1–10 sec.

	 Retry Use :	 Select whether or not to retry communications (ON/OFF). 

	 Retry Interval :	 The interval between communication retries (30–3600 sec.)
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Tag Settings
Procedure

1.	 Click the Tag Setting tab or choose View > Tag setting from the menu bar.

Drag to select a range of items (up to 300 channels can be selected)

Turns all selected 
items ON/OFF

Click to display a list

Register numbers are filled from the first cell in the selection 
to the last, each line being given a register number 1

Select/deselect all items

Click to turn a single item ON/OFF

Copies the setting in 
the first item of the 
selection to all of the 
items in the selection

2.	 Enter the following settings.  

	 Tag number: 		  ON (blue)/OFF (gray)

	 Port: 			   NONE, COM1–COM9, Ether1–Ether16

	 Modbus address: 		 Enter the address for the Modbus device.  

	 Modbus function: 		 03 or 04

	 Modbus register numbers: 

		 For Modbus function 03, 40001-49999, 400001-465535

		 For Modbus function 04, 30001-39999, 300001-365535

	 Modbus data type: 	� Depends on the Modbus device header.  (See page 
3-8, “Data Type”)

	 Scaling coefficient: 	 (See page 3-10, “Data Scaling”)

	 Scaling offset: 		  (See page 3-10, “Data Scaling”)

	 Decimal position: 		 An integer from 0–4

	 Span Lower/Upper: 	� Setting range varies depending on the decimal 
position.  (See page 3-5, “Upper/Lower Limit of Span”)

	 Unit:			   Enter up to 6 alphanumeric characters.

	 Tag name:		  Enter up to 16 alphanumeric characters.

2.2  Entering Environment Settings
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2.2  Entering Environment Settings

Group Settings
Procedure

1.	 Click the Group Setting tab or choose View > Group setting from the menu bar.

Select/deselect
all items

Drag to select a 
range of items

Restore the default 
color to all tags

Click here to display 
the Tag No. dialog box.

Tag numbers are filled from the first cell in 
the selection to the last, each line being given 
a tag number 1 higher than the last

Turns all selected items ON/OFF
Click to turn a single item ON/OFF

2.	 Enter the following settings.  

	 Group name: 	 Enter up to 30 alphanumeric characters.

	 No.: 		  ON (blue)/OFF (gray)

	 Tag No.: 		 Select the tag number in the Tag No. dialog box.

	 Color: 		  Assign colors to tags.

TCP/IP Settings for the Monitor Server Port 
Procedure

1.	 Click the Port Setting tab or choose View > Port setting from the menu bar.

			    

2.	 Enter the port number used to transfer data loaded from a Modbus device to 
DAQLOGGER or Remote Monitor.   The port number need not be changed 
unless a problem occurs.
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2.3	 Saving and Restoring Environment Settings

Saving Environment Settings
Procedure

1.	 Click the Save button or choose File > Save from the menu bar.

					   
Save button

	 The current settings are saved.

Restoring Environment Settings
This procedure clears all settings currently being entered and restores the most recently 
saved settings.  

Procedure
1.	 Choose File > Revert from the menu bar.  
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2.4	 Reading Data from a Modbus Device and 
Transferring the Data as the Monitor Server

When you run the executable function, data is read in from the Modbus devices, the PC 
becomes the monitor server, and data is transferred to DAQLOGGER or Remote Monitor.  
The executable function can be run as a process or a service.  When run as a process, 
the executable function closes when logging off Windows.  When run as a service, the 
executable function is registered in Windows as an automatically executable service.  
When run as a service, the executable function continues processing even when the 
user has logged off of Windows.  Also, the executable function is run automatically as 
soon as the PC is turned ON (prior to log in).  However, the software can only be run as a 
service by a user with Administrator privileges. Services cannot be executed when using 
Windows Vista.

Note
The maximum number of DAQLOGGERs or Remote Monitors that can be connected at once is 
16.

Running the Executable Function
Procedure

1.	 Enter environment settings.  (See section 2.2, “Entering Environment Settings.”)  
Running from the Menu Bar

2.	 To run the function as a process, click the Process Execution button or choose 
Execute > Process from the menu bar.

					     Process execution button
Service execution button

	 To run the function as a service, click the Service execution button or choose 
Execute > Service from the menu bar.  

	 The Practice Status item in the Practice/Status tab displays “Process” or “Service,” 
as well as the name of the connected client, connection status, and the addresses 
of any disconnected DAQLOGGERS and Remote Monitors.
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Running the Executable Function from the Practice/Status Tab 
2.	 Select the type of execution from the Practice/Status tab, then click the Practice 

button.  

	 The Practice Status item displays “Process” or “Service,” as well as the names 
of connected clients, the connection status, and the addresses of disconnected 
DAQLOGGERS and Remote monitors.

					   

Stopping the Executable Function
Procedure

Stopping from the Menu Bar
1.	 Click the Stop button or choose Execute > Stop from the menu bar.

					   
Stop button

	 The Practice Status item shown on the Execution/Status tab displays “Stop.”  

Stopping the Executable Function from the Execution/Status Tab 
1.	 Click the Stop button on the Execution/Status tab.  

	 “Stop” is displayed for the practice status .

2.4  Reading Data from a Modbus Device and Transferring the Data as the Monitor Server
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2.5	 Performing the Loop Back Test 

Performing the Loop Back Test

Note
The loop back test or service cannot be performed while other processes or a services are 
running.

Procedure
1.	 Choose Test > Loop Back Test from the menu bar.  

	 The Loop Back Test dialog box opens.

					   

Select/deselect
all items

Drag to select a 
range of items

2.	 Drag to select the addresses on which you wish to perform the loop back test.  

3.	 Click Practice.

	 The result appears in the status column. 

	 OK: Normal

	 Not OK: No response
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 Executing the Test 
Procedure

Starting the Test
1.	 Choose Test > Test from the menu bar.  

	 The Test Exec dialog box is displayed.

					   

Drag to select a 
range of items

Select/deselect
all items

2.	 Drag to select the tag numbers on which you wish to perform the test.  

3.	 Click Practice.

	 The scaled result is displayed. 

Stopping the Test
4.	 Click STOP.  

	 The test stops.  

2.5  Performing the Loop Back Test 
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2.6	 Viewing the Status of the Executable Function 
and Retrying Communications

Viewing the Status of the Executable Function
Procedure

1.	 Click the Practice/Status tab or choose View > Execution/Status from the menu 
bar.  

	 The practice type, practice status (running as process, running as service, or 
stopped), client connection status, and communication cutting addresses are 
displayed.

					   

The practice status is 
displayed using colors
Green: Normal
Gray: Stopped
Blinking red: Error
Yellow: Data dropout 

occurred and 
communication is retried 
(communication paused)

If Use retry is turned OFF on the Scan Interval 
Setting tab, click here to retry communication 
if a communication error occurs.

The software retries communication until it is 
restored and displays up to 200 addresses that 
ended in a communication error only if Use retry 
is turned ON the Scan Interval Setting tab
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Note
•	 Click the Start button to download data from the Modbus devices.  The interval at which data 

is downloaded is determined by the data acquisition conditions (scan interval, timeout time, 
and number of retries). 

•	 If a warning message is displayed (code Wxxxx), the lamp that displays the connection 
status by color does not blink red.  

•	 When an error occurs and the lamp blinks red, the Error Indicator dialog box appears.  If you 
close the dialog box, the lamp turns green.

Retrying Communications
1.	 Click the Communication Retry button.

	 Retries communications. (Retry time)  

2.6  Viewing the Status of the Executable Function and Retrying Communications
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2.7	 Viewing Version Information

Procedure
1.	 Click the About button or choose Help > About from the menu bar.  

	 The Version dialog box opens.

					   

Version

Company name
User name
License number



3-1IM WX1-05E

1

2

3

Index

D
etailed D

escription Functions

Chapter 3	 Detailed Description Functions

3.1	 Overview

GateMODBUS performs serial communications with Modbus devices and acquires data 
at regular intervals. Through the monitor server function, the acquired data is transferred 
to DAQLOGGER or Remote Monitor via Ethernet.  The following is a list of the features 
of each software function. 

Environment Setting Functions
Environment setting functions are used to enter all environment settings required to run 
the executable function, and are also used to run/stop the executable function.  
•	 Serial Port Settings 
	 Baud rate
	 Parity
•	 Ethernet port to be used 
	 IP address or host name
	 Port number
•	 Data Acquisition Conditions
	 Scan interval
	 Timeout time
	 Retries
•	 Tag Settings
	 Communications port	
	 Modbus address
	 Modbus function
	 Modbus register number
	 Modbus data type
	 Scaling coefficient
	 Scaling offset
	 Decimal place
	 Upper/lower limit of span
	 Unit
	 Tag name
•	 Group Settings
	 Tag assignments
	 Tag colors
	 Group name
•	 TCP/IP Settings for the Monitor Server Port 
•	 Running/Stopping Executable Function
	 Running of the executable function as a service
	 Running of the executable function as a process
	 Stopping the executable function
•	 Performing Tests (Data Acquisition)
•	 Loop Back Test
•	� Communication Retry ON/OFF for the Executable Function, Retry 

Interval, and Reset
•	 Status Display of Executable Function
	 Practice status display (stopped, running as a service, running as a process)
	 The client connection status is displayed if DAQLOGGER or Remote Monitor is the 

client. 
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Executable Function
Features of the executable function are as follows:
•	 Running as a process and as a service is possible.
•	 Data is acquired from Modbus devices at regular intervals.  
•	 Retries communications.
•	 Runs as a monitor server if DAQLOGGER or Remote Monitor is the client.  

3.1  Overview of Functions
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3.2	 Detailed Description of Functions

Communication Port
The communications ports available to GateMODBUS are the COM1–COM9 serial 
(RS-232) ports the Ether1 to Ether16 Ethernet ports.  The following items are specified in 
the Serial Setting tab. 
Serial port setting
•	 Baud rate (4800, 9600, 19200, or 38400 bps)  
•	 Parity (None, Even, or Odd)
Ethernet port setting
•	 IP address or host name
•	 Password

Note
The Modbus protocol’s RTU (remote terminal unit) mode prescribes stop bit 2 for no parity, and 
stop bit 1 for odd or even parity.

Modbus Communications
GateMODBUS supports communications using the Modbus/RTU (serial) and Modbus/
TCP (Ethernet) protocols.  The functions and registers used by GateMODBUS for data 
logging are as follows:

Function 03 04
Description Read holding register Read input register
Register numbers that can be loaded: 40001–49999 400001–465535

30001–39999 300001–365535

Also, you can execute the following functions on the configurator to display the 
connection status with Modbus devices.  
Function 08
Sub-function 00
Description Loop back test

Note
GateMODBUS does not support the Modbus protocol’s Modbus/ASCII mode.
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Logical Configuration
Item Description Limit
Tag Indicates one data item. 300
Group Assigns tags.  Up to 32 tags can be assigned to a group. 50

Logical Configuration Diagram

		

TAG001

GateMODBUS

TAG002

TAG003

TAG004

TAG200

Tag

Assignments

Group

Group

Acquisition Conditions
The following items are included in the acquisition conditions.  
•	 Data scan interval (0.5–3600 sec)
	 For information on the data acquisition operation, see page 3-6, “Acquiring Data at 

Fixed Intervals.” 
•	 Timeout time (1–10 sec)
•	 Retry Use (ON/OFF). 
•	 Retry Interval (30–3600 sec.)

Tag
A tag is a name for a data value.  You can use up to 100 tags with GateMODBUS.  Data 
obtained from the Modbus registers is assigned to each tag.  The following items are 
included in tag settings.  
•	 Used serial ports (COM1–COM9) and Ethernet ports (Ether1 to Ether16) 
•	 The read Modbus function (03 or 04)
•	 Register numbers read
	 For Modbus function 03: 40001–49999, 400001–465535
	 For Modbus function 04: 30001–39999, 300001–365535
•	 Data Type
	 See page 3-8, “Data Type.”
•	 Scaling variable	
	 See page 3-10, “Data Scaling.”
•	 Decimal place
•	 Upper/lower span value
•	 Tag name
•	 Unit

3.2  Detailed Description of Functions
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Tag Name

Enter a tag name as needed.  You can enter up to 16 alphanumeric characters. Tags 
can be downloaded (tag data is received) using a DAGLOGGER tag software or Remote 
Monitor that is connected to GateMODBUS.  

Unit
Enter a unit as needed.  You can enter up to 6 alphanumeric characters.  The unit string 
is the unit string on the DAQLOGGER or Remote Monitor connected to GateMODBUS.  

Decimal Place
Enter a decimal place of 0, 1, 2, 3, or 4.  This value is the decimal place used when 
DAQLOGGER or Remote Monitor is connected to Gate-MODBUS for monitoring.  

Upper/Lower Limit of Span
Enter the upper and lower limit values of span.  The available setting range is as follows:
Decimal Place Setting Range
0 –10000000000000000 to 10000000000000000
1 –1000000000000000.0 to 1000000000000000.0
2 –100000000000000.00 to 100000000000000.00
3 –10000000000000.000 to 10000000000000.000
4 –1000000000000.0000 to 1000000000000.0000

This value is the default setting used when DAQLOGGER or Remote Monitor is 
connected to GateMODBUS for monitoring.  

Groups
You can combine tags into groups. Up to 50 groups can be created.  Up to 32 tags can 
be assigned to a group. The following items are included in group settings.  
•	 Tag assignments: 	 Up to 32 tags can be assigned to a group.  
•	 Color of assigned tags: 	 The default color when connected to Remote Monitor.  
•	 Group name: 	 Up to 30 alphanumeric characters can be input.

Note
	 Group settings cannot be used by DAQLOGGER.  They are only available when connected 
to Remote Monitor.

  

Tag Assignments
Tags can be assigned to groups.  Up to 32 tags can be assigned to a group.  The 
tags assigned here are the default values when Remote Monitor is connected to 
GateMODBUS.  

Tag Colors
Specify colors for tags assigned to groups.  The tag colors specified here are the default 
values when Remote Monitor is connected to GateMODBUS.  

3.2  Detailed Description of Functions
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Group Names
You can assign names to groups.  Names can contain up to 30 alphanumeric characters.  
The group names specified here are the default values when Remote Monitor is 
connected to GateMODBUS.  

Acquiring Data at Fixed Intervals
Using GateMODBUS, data can be acquired concurrently on each port.  Therefore 
data is logged more efficiently when connecting each Modbus device to a separate 
port rather than connecting several Modbus devices to a single port.  Also, registers 
occurring in a continuous sequence on 1 instrument are read all at once.  Therefore, the 
more sequentially continuous registers there are, the more efficiently data is acquired.  
However, if a register within the sequence experiences an error, the error applies to all 
registers in the sequence.  

For example, given the three registers below, TAG001–TAG003 are read all at once at 
each scan interval.  
Tag COM Port Modbus Address Register numbers read
TAG001 COM1 1 30001
TAG002 COM1 1 30002
TAG003 COM1 1 30003

Data Dropout
If data is being read at the timing shown below, data is dropped. Data dropout can occur 
in the following circumstances.  
•	 If the time required to read the tags is longer than the scan interval
	 In the figure below, by the time the tags at T1 have been read, T2 has already passed 

and T3 begins.  Therefore, the tags to have been read at T2 were dropped.

TAG001 TAG002 TAG003 TAG004 TAG001 TAG002 TAG003 TAG004

T T1 = T + ∆t T2 = T + ∆t x 2 T3 = T + ∆t x 3
Interval: ∆T

Data reading at time T Data reading at time T1

Time

Data
dropout
occurs

Time

Timing of Data Reading

3.2  Detailed Description of Functions
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	 In this case, as much time as possible must be given to interval ∆T to acquire all tags 
assigned to the port. 

	
•	 When data reading times out due to such instances as noise interference during 

communication, or when a Modbus device’s power turns OFF
	 In the figure below, with the data reading at time T, the reading of all tags occurs 

within the logging interval ∆T, but with data reading at time T1, TAG0003 times out, 
and data reading at time T2 is dropped.

TAG001

TAG002

TAG003

TAG004

TAG001

TAG002

TAG004

T T1 = T + ∆t T2 = T + ∆t x 2 T3 = T + ∆t x 3
Interval: ∆T

Data reading at time T Data reading at time T1

TAG003 times out

Data
dropout
occurs

Time

Time

Timing of Data Reading

Enter as short of a timeout time as possible, keeping in mind the processing power and 
baud rate of the Modbus device performing communications with GateMODBUS.  As you 
can see from the figure above, if the timeout time is long data can be dropped not only 
from tags that timed out, but also from adjacent tags even if they would have responded 
normally.  

Timeout Operation
When reading tag data, after sending a register value request message to the Modbus 
device, if the message is not received within the specified timeout time that tag is 
considered to have timed out.  When the setting of “Retry Use” is turning on, retrying is 
executed for tag which have timeout.

Resetting the Timeout Counter
You can reset the timeout counter for the executable function from the configurator.  
When resetting the timeout counter, the retries of tags for which data acquisition was 
stopped due to the executable function having timed out begin again at 1, and data 
reading is performed.  

3.2  Detailed Description of Functions
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Data Type
With the Modbus protocol, the data type within the read registers is not defined.  
Therefore, the data type in the read registers depends on the Modbus device’s 
manufacturer.   GateMODBUS supports the following data types.  

Signed 16–Bit Integer (INT16)
Enter this setting if a signed 16–bit integer is assigned to the Modbus device registers.

GateMODBUS tag data
Modbus registers

Signed 16–bit

Register number (small)

Register number (large)

Unsigned 16–Bit Integer (UINT16)
Enter this setting if an unsigned 16–bit integer is assigned to the Modbus device 
registers.

GateMODBUS tag data
Modbus registers Register number (small)

Register number (large)Unsigned 16–bit

Signed 32–Bit Integer High/Low (INT32_B)
Enter this setting if a signed 32–bit integer is assigned to the Modbus device registers 
and the register numbers are assigned from high to low starting with the smallest register.

GateMODBUS tag data
Modbus registers Register number (small)

Register number (large)
Signed 32–bit integer (low)

Signed 32–bit integer (high)

Signed 32–Bit Integer Low/High (INT32_L)
Enter this setting if a signed 32–bit integer is assigned to the Modbus device registers 
and the register numbers are assigned from low to high starting with the smallest register.

GateMODBUS tag data
Modbus registers

Register number (small)

Register number (large)

Signed 32–bit integer (low)

Signed 32–bit integer (high)

Unsigned 32–Bit Integer High/Low (UINT32_B)
Enter this setting if an unsigned 32–bit integer is assigned to the Modbus device registers 
and the register numbers are assigned from high to low starting with the smallest register.

3.2  Detailed Description of Functions
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Unsigned 32–bit 
integer (low)

GateMODBUS tag data
Modbus registers Register number (small)

Register number (large)

Unsigned 32–bit 
integer (high)

Unsigned 32–Bit Integer Low/High (INT32_L)
Enter this setting if an unsigned 32–bit integer is assigned to the Modbus device registers 
and the register numbers are assigned from low to high starting with the smallest register.

Unsigned 32–bit 
integer (low)

GateMODBUS tag data Modbus registers Register number (small)

Register number (large)

Unsigned 32–bit 
integer (high)

32–Bit Floating Point High/Low (FLOAT_B)
Enter this setting if an unsigned 32–bit floating point is assigned to the Modbus device 
registers and the register numbers are assigned from high to low starting with the 
smallest register.

GateMODBUS tag data
Modbus registers Register number (small)

Register number (large)

32–bit floating point (high)

32–bit floating point (low)

32–Bit Floating Point Low/High (FLOAT_L)
Enter this setting if an unsigned 32–bit floating point is assigned to the Modbus device 
registers and the register numbers are assigned from low to high starting with the 
smallest register.

GateMODBUS tag data
Modbus registers Register number (small)

Register number (large)
32–bit floating point (high)

32–bit floating point (low)

3.2  Detailed Description of Functions
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Data Scaling
There are times when the values obtained by reading registers during Modbus 
communication are not physical values.   
GateMODBUS performs the following calculations on Modbus register values.  
	 X = A • x + B

	 X:	calculated result
	 x:	 Modbus register value
	 A:	Coefficient
	 B:	Offset

The user can specify a desired value for coefficient A and offset B above using the 
configurator.  

Running/Stopping Executable Function
The configurator starts and stops the executable function.  There are two execution 
methods, process and service.  Process execution starts the application as any normal 
program.  When started as a process, the executable function closes when logging off 
Windows.  When started as a service, the executable function is registered in Windows 
as an automatically executable service.  When started as a service, the executable 
function continues processing even when the user has logged off of Windows.  Also, 
the executable function is run automatically as soon as the PC is turned ON (prior to log 
in).  However, the function can only be run as a service when using Windows 2000 or 
Windows XP by a user with Administrator privileges. Services cannot be executed when 
using Windows Vista.

Loop Back Test
Using the configurator, you can perform the Modbus function 08 loop back test on 
each Modbus device connected to GateMODBUS.  This sub-function is 00, and during 
normal operation, data having the same contents as data sent to the Modbus device 
by  GateMODBUS is returned from the Modbus device.  The result of the loop back test 
is displayed as either Normal or No Response on the configurator.  If the loop back test 
results in no response, it may indicate a problem with the communication cable, baud 
rate or parity mismatch, or a wrong Modbus address.  

Test Acquisition
You can perform a test acquisition on each tag using the configurator.  For the test 
acquisition, data is read from the registers of the Modbus devices specified for each tag, 
the results are scaled per specified values and displayed as digital values.  From this, 
you can determine whether the COM port, Modbus address, Modbus register, scaling 
coefficient, and decimal place for each tag is correct.  

Monitor Server Function
GateMODBUS takes data read in from the Modbus devices and utilizes its monitor server 
functionality to transfer the data to DAQLOGGER or Remote Monitor.  The maximum 
number of DAQLOGGERs or Remote Monitors that can be connected at once is 16.  

Status Display of Executable Function
The status display function allows you to display the following status items for the 
executable function.  
•	 Practice status (stopped, running as a service, running as a process)
•	 Tags disconnected due to timeout 
•	 PCs connected to DAQLOGGER and Remote Monitor as a monitor server

3.2  Detailed Description of Functions
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3.3	 Messages and Corrective Actions

Error
No. Message Corrective Actions
E211 Cannot write to file. Check if the disk capacity is sufficient or if the file systems is normal.
E212 Cannot read file. Check if the file exists and is supported by the software or if the file system is 

normal.
E213 Cannot open file. Check if the file exists and is supported by the software or if the file system is 

normal
E401 Communication error. Check if the recorder connected for communication is powered on and if the 

cable is properly connected.  Also check the following items according the 
communication type.
• For Ethernet
  �Check if address settings are correct; the TCP/IP protocol is installed in 
Windows; the Ethernet card is properly installed.

• For RS-232 and RS-422-A
  �Check if the baud rate settings match; the port (COM1 to COM9) settings 
match, the address settings are correct (RS-422-A); the serial port of the PC 
is active and the appropriate cable is being used.

E402 Communication timeout. -
E403 Cannot open a communication 

port.
Same as E401.

E501 Invalid license number. Please 
reinstall the software.

Install the software again.

E1010 Execution of a process failed. Check whether an executable function exists, or whether its files are 
damaged.  If this error appears frequently, reinstall the software.

E1011 Execution of a service failed. Check whether an executable function exists, or whether its files are 
damaged.  If this error appears frequently, reinstall the software.

Message
No. Message
M1201 Model determination was successful.
M1210 Setting changes saved before execution.

Executable Function Messages
No. Message Corrective Actions
W[631] Data Lack Reduce the number of acquired data points or connected instruments, or 

lengthen the scan interval. 
E[673] Cannot open communication Same as E401.
E[674] Communication error Same as E401.
E[675] Communication time out Same as E401.
E[800] CRC check error A CRC error was detected.  Check the communication status.
E[801] Invalid handle. Check the communication status.
E[802] Error respond Check the communication status.
E[804] Invalid command -
I[606] Recovery Communication Connection recovered.
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